Author Topic: Microsoft Edge web browser  (Read 205 times)

0 Members and 1 Guest are viewing this topic.

noquiexis

  • Sr. Resident
  • ****
  • Posts: 3367
  • Northwest Ohio USA
    • Five Lines - Four Spaces
Microsoft Edge web browser
« on: December 04, 2017, 10:40:33 PM »
Microsoft Edge web browser tested

     The Microsoft Edge web browser should not be used to access this forum. That browser is incapable of using many of the features included with Simple Machines Forum (SMF) software. Below is my report based on personal experience gathered on 4 December 2017. You can log in and read the posts with Microsoft Edge, but replying to posts or starting a new topic will be problematic.



     In April of 2009 I purchased a Dell Inspiron 530 computer (now referred to as "My computer"). That computer has two internal hard drives. The larger of the two hard drives (500Gb) has the Windows 7 Graphic User Interface (GUI). It pains me to think of Windows as an "Operating System" regardless of what Microsoft calls it. The 500Gb hard drive has the Microsoft Internet Explorer and the Google Chrome web browsers installed.

     I first got Windows 10 when it was given out for free. I put it on the second internal hard drive (250Gb). I had to reboot that computer, go into the BIOS settings, and select the second hard drive as my primary boot device in order to bring up the Windows 10 GUI. My first impression of Windows 10 was not good, so I hardly ever booted into it. The 250Gb hard drive has the Microsoft Internet Explorer, Microsoft Edge, and the Google Chrome web browsers installed.

     I checked the Microsoft Edge web browser on another Simple Machines Forum (SMF) at the Jim Butcher Online website. That website used SMF version 2.0, which is even older than that used at Our Doll Community. One of the things that I discovered then was that the Microsoft Edge browser could not handle the formatting buttons or the smileys when you post a new topic or reply to an existing topic.

     In the summer of 2017, I decided to purchase a second computer, a Dell XPS 8920 computer that I refer to as "Feodora's computer". It also has two internal hard drives, but only has the Windows 10 GUI on the primary boot hard drive (1TB). That hard drive has the Microsoft Internet Explorer, Microsoft Edge, and the Google Chrome web browsers installed. I wanted to see if the Microsoft Edge browser fared any better, since it was updated along with Windows 10.

Microsoft Edge browser

     The first thing that I noticed is that the Microsoft Edge browser does not have a Menu bar, and no Toolbars selection menu. Keyboard shortcuts for Microsoft Edge were discovered by users.
"Since there is not an official list of shortcuts by Microsoft yet, this will be a list of shortcuts that I and anyone that posted has found so far until then. This tutorial will be kept updated.
 If you know of any keyboard shortcuts that are not already listed in this tutorial, then please feel free to post a reply with it to help others."

    On the Edit window (for NEW TOPIC and REPLY) the editing area cannot be resized. There is no resize handle on the bottom border. There is a scroll bar on the right side of the editing pane, but scrolling through a long post is tedious.

     The Formatting buttons (some listed below) do nothing when you click on them. They should automatically add the formatting tags whether you have text highlighted or not. I manually added the tags to see if the formatting would show up on the Preview screen. Smileys do not work, either.

                                                                             
Bold  Italic  Underline  Strikethrough  Preformatted Text  Left Align  Center  Right Align

     Next to those buttons is a set of drop-down menu options for Font Face, Font Size, and Change Color. Those menus do drop down when you click on them, but the Microsoft Edge web browser fails to place the formatting tags in the edit pane.



     The Microsoft Edge browser will work for the version of Ajax Chat used here at Our Doll Community (ODC). The chat Smileys work, but there are no chat sounds. If you are using Microsoft Internet Explorer with Windows 10, the older version of Ajax Chat used at ODC stopped working properly as of the Windows 10 "Creators Update" of October 2017. After the Windows 10 "Features Update" on 6 Nov 2017 I could not log into ODC chat with Internet Explorer at all.

     I and other users tried the Google Chrome web browser, which does work as expected for the forum, but does not play sounds used in the chat room.

     I do not have the other popular web browsers, so those who do may add their experiences to this topic. I do not have Unix, MAC, or any Graphic User Interface other than Microsoft Windows. I use two desktop computers to access the internet and the World Wide Web. I have no experience with any other device.

"Like a bolt out of the blue
 Fate steps in and sees you through
 When you wish upon a star
 Your dreams come true"

   Cliff Edwards as Jiminy Cricket (1940)

Trixie and Dixie are Private Secretary inflatable dolls.
Esperanza is a Tera Patrick inflatable doll.
see my gallery for their pictures

Feodora is an Anatomical Doll, Face 3 Body 3 Set 2 Set 3 Set 4

Szalinski

  • Sr. Resident
  • ****
  • Posts: 1188
  • Reality is for those with no imagination.
    • Chris'Z Corner
Re: Microsoft Edge web browser
« Reply #1 on: December 05, 2017, 09:04:21 PM »
I use Epic, which is based on Chromium, but with all the tracking software replaced with tracking blockers. The only problem I've had with it here is embedded videos won't play.
Heaven help me, I have been dating a real human female.
.........And enjoying it!

My cross country bike ride | Flickr albums for my dolls

betamkii

  • Resident
  • ***
  • Posts: 137
Re: Microsoft Edge web browser
« Reply #2 on: December 11, 2017, 08:27:27 PM »
I use an older version of Firefox and the only thing that doesn't work for me is the Insert Quote feature when editing a post. Clicking "Quote" on a post still works (as seen below).

I use Epic, which is based on Chromium, but with all the tracking software replaced with tracking blockers. The only problem I've had with it here is embedded videos won't play.

The main reason embedded videos here don't work anymore is because Youtube discontinued it's Flash player, so the Youtube videos using the [Flash] tag will not work. It's possible that Youtube videos could theoretically still be embedded, but I don't know if the forum supports HTML5. Videos from other sites, like Vimeo, should still work. This is, of course, assuming you have Flash Player installed.
Owner of a Sinthetics 2D Alicia/Celeste - 12/12/16

Szalinski

  • Sr. Resident
  • ****
  • Posts: 1188
  • Reality is for those with no imagination.
    • Chris'Z Corner
Re: Microsoft Edge web browser
« Reply #3 on: December 11, 2017, 08:37:47 PM »
I remember posting a question as to whether anyone else was getting error messages in YT embeds, but it seemed almost noone else was having any trouble, so I figured it had something to do with Epic's interpretation of this forum.  :facepalm:
Heaven help me, I have been dating a real human female.
.........And enjoying it!

My cross country bike ride | Flickr albums for my dolls

noquiexis

  • Sr. Resident
  • ****
  • Posts: 3367
  • Northwest Ohio USA
    • Five Lines - Four Spaces
Re: Microsoft Edge web browser
« Reply #4 on: December 12, 2017, 08:44:43 PM »
     On another topic, I suggested just posting the link for the YouTube video, which just opens a new tab or window.

   Example 1: Tina Louise - It's Been A Long Time (1957)
   Example 2: Tina Louise - It's Been A Long Time (1957) - https://www.youtube.com/watch?v=lL9YIpp_rlk

;) ;) ;)
"Like a bolt out of the blue
 Fate steps in and sees you through
 When you wish upon a star
 Your dreams come true"

   Cliff Edwards as Jiminy Cricket (1940)

Trixie and Dixie are Private Secretary inflatable dolls.
Esperanza is a Tera Patrick inflatable doll.
see my gallery for their pictures

Feodora is an Anatomical Doll, Face 3 Body 3 Set 2 Set 3 Set 4

Feguro

  • Resident
  • ***
  • Posts: 108
Re: Microsoft Edge web browser
« Reply #5 on: December 20, 2017, 02:21:33 PM »
Hi Noquiexis,

I've opened the Console with F12 key while running MS Edge.
As I clicked the Reply Button for reply/edit a post I saw an Error Message in the F12 window naming a HTML5 problem.
Then I clicked the Emulation Tab in the F12 Window and changed the Emulation to IE11.
I clicked again the Reply Button and this Error Message didn't come up again.

Perhaps it helps when you run the Edge in emulation mode and problems will fixed then. But I don't know how to run EDGE generell in emulation mode. I use Chrome. Perhaps this information will be find in i-net.

Here is a Link to a generel shortcut side. https://www.w3schools.com/tags/ref_keyboardshortcuts.asp

The editor itself looks like a html <TEXTAREA> or editable <DIV> with the format functionality around. The named shortcuts should work except the editor designer has not implemented key event handler for them. When looking at end of the editor it seems he has, because he name shortcuts for submit/preview which originally have other functions save/print.
Sinthetics - Body 1H Celeste, YL 150 160, 140, JY 166 156, 161

j.biv

  • Resident
  • ***
  • Posts: 112
Re: Microsoft Edge web browser
« Reply #6 on: December 21, 2017, 10:49:47 PM »
I am using Opera for this site and another not-so-family-friendly site. That if my son is around and I want to show him something, Firefox is clean. I stopped using the microsoft browsers in win98. Known to be slower and less secure than Firefox and Chrome.

Just my two cents.

Jeb